渋谷ほととぎす通信

完全趣味でやってるUnityメモ。説明できないところを説明できるようにするための個人ブログ。昨日の自分より少しでも大きくなれるように。。。 ※所属団体とは一切関係がありません

Xcode9.4.1でトラブるので、一旦Xcode8.3.3にダウングレードしてみたが...


f:id:esakun:20161208031621p:plain

TestFlightを使ってテストで配信したいだけなのだが、Xcode9.4.1でトラブるので一旦8.3.3にダウングレードしてみたってことなのですが、、、

f:id:esakun:20180701224238p:plain

iTunes Store operation failed.
SDK Version Issue. This app was built with the iOS '10.3' SDK. All new iOS apps submitted to the App Store must be built with the iOS '11.0' SDK or later, included in Xcode [9.0] or later. Please update Xcode and rebuild your app.

案の定このような致命的なエラーに見舞われました。
というのも、2018年4月以降 のアプリにはiOS11 SDKを含むことが必須になったらしく、Xcode9以上を使わなければならないようです。

ということで、もう少しXcode9と戦ってみようかと。

参考